Members
  • Total Members: 294
  • Latest: shawnb
Stats
  • Total Posts: 3649
  • Total Topics: 1264
  • Online Today: 22
  • Online Ever: 223
  • (April 06, 2015, 12:26:53 PM)
Users Online
Users: 0
Guests: 9
Total: 9
TMART
VigLink badge

Author Topic: What's your setup?  (Read 2389 times)

Offline JayMan

  • Newbie
  • *
  • Posts: 6
  • Music Addict
    • View Profile
What's your setup?
« on: September 06, 2012, 06:08:19 AM »
Hi there guys.

I started this thread so everyone can share what their setup is when they play.

I've had so many different answers to this question in the past because the possibilities are basically limitless.  Another reason for asking is because I can't help but think when I'm playing that something is still missing from my setup. 

Anyway mine is as follows:
Guitar: ESP Ltd EC100QM or Ibanez Gio GART60
Pedal(s): Boss ME-70 and Boss OD-1
Amplifier: Roland Cube 30X
Cables: Peavey adn ROCKcable

What you guys using?



Austin

  • Guest
Re: What's your setup?
« Reply #1 on: September 06, 2012, 03:00:07 PM »
I stay acoustic, so:

Fender DG200SCE Acoustic-Electric Guitar with Rosewood Back and Sides Natural :)

I have electric and stuff but I play it rarely so I stick with Acoustic :)

Offline Fastfingers

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: What's your setup?
« Reply #2 on: September 06, 2012, 08:17:10 PM »

My gear

Gretsch Country Club
Freshman FJ1
Blueridge BR-163
Washburn WD10 SCE
Ibanez EWV30SYE
Freshman FA1AWR
Vintage VE300
Epiphone hummingbird limited edition ebony
Alliance VP TMOS 10J
Yamaha F310
Hohner Concerta
3/4 Romanian upright Double Bass
Yamaha E413 Keyboard
Fender Frontman FM65R
An angry man, is never reasonable, a reasonable man is never angry..

Offline paulnoise

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
Re: What's your setup?
« Reply #3 on: April 22, 2013, 03:49:18 PM »
My setups
Guitar
Antoria telstar deluxe / bcrich warlock
Boss ds1 and zakk wylde overdrive
Peavey bandit 112

Bass
Peavey t40 (1980) /epiphone blackbird
Peavey firebass 700


sent on the move using tapatalk